I'm are having a problem trying to get data via Facebook's Graph API from a leadgen object, from a particular Facebook business.

A page admin user logs in and we request these permissions: manage_pages, pages_show_list, leads_retrieval, public_profile.

Then we set up a webhook to obtain leads from a leadgen form.

We also create a long lived token and store it in the server. Once we have all this setup, Facebook sends us any leadgen data via the configured webhook.

The data looks like this (sensitive data omited):

{
    "entry": [
    {
        "changes": [
        {
            "field": "leadgen",
            "value": {
                "created_time": ...,
                "page_id": "...",
                "form_id": "...",
                "leadgen_id": "..."
            }
        }
    ],
    "id": "...",
    "time": ...
    }
  ],
  "object": "page"
}

We retrieve the leads data via the /{leadgen_id} endpoint, and the long lived token.

We havent had any issues until today that we tried to connect to another business and recieved this:

CRM access has been revoked from Lead Access Manager.

After some research we noticed that we had to ask the user to enable our Facebook app in: Business Settings -> Integrations -> Leads Access -> CRM

It seems that our other users had the default settings set in the Manage Leads Access: By default, all Page admins and connected CRMs for {company name} can access leads.

But on the company that had activated the Lead Access Manager, when we query the /{leadgen_id} endpoint we recieve this error:

{
  "error": {
    "message": "Unsupported get request. Object with ID '...' does not exist, cannot be loaded due to missing permissions, or does not support this operation. Please read the Graph API documentation at https://developers.facebook.com/docs/graph-api",
    "type": "GraphMethodException",
    "code": 100,
    "error_subcode": 33,
    "fbtrace_id": "..."
  }
}

We tried accessing https://developers.facebook.com/tools/visibility, but It does not give us any insight on the error.

Besides that we are also getting an error whe we access https://developers.facebook.com/support/

App health status
Your app received privacy errors during a recent Graph API request. As a result, your app may not function properly until the issue is resolved.

I'm guessing that we have to ask for some other permission or something, but its not clear what or which permission we should ask for in this case.

Any ideas?

1 Answer

1

Ok, so its seems the issue was because one of the users created the token, and then it was updated by another user, for some reason this caused the error. Both users are admins from the same page.

I still need to debug the exact cause of this, but the issue was that we where sending another token to the Graph API.

Your Answer

Upload

You can also provide a link from the web.

Log in

or

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

http://mssss.yulina-kosm.ru