-1
I am working on a react-native project and I run it on emulator android(AVD manager)

i have run adb reverse tcp:8081 tcp:8081 at cmd , but still my emulator stuck Whenever i am changing my project and reload emulator!

Development Operating System:Windows 10

React Native version: 0.55.4enter image description here

  • What is running at 10.0.2.2, and can the Android (Emulator) properly route packets to that address? – Matt Clark Jul 31 '18 at 22:28
  • i don't know what is running at 10.0.2.2!!, when i am running react-native run-android ,it build successful – Mahdavi Aug 1 '18 at 8:37
0

The latest version of React Native change the port of emulator by somehow but the older not. Anyway, please reference to this link . Then it will help you sort it out.

Cheer!

  • i don't find Debug Server port & port for device at android emulator (AVD) – Mahdavi Aug 1 '18 at 8:26
  • In emulator, press Ctrl+M to open Developer menu. – nahoang Aug 1 '18 at 9:46
  • i had done it but no action was taken – Mahdavi Aug 1 '18 at 14:01
0

Maybe your 8081 port is already in use.

Try the first solution in here https://facebook.github.io/react-native/docs/troubleshooting

$ sudo lsof -i :8081

$ kill -9

After that,

$ cd YourProject

and

$ npm start

this should help you debugging the packager

0

Your issue can also relate to watchman, try the following commands (I used them on linux ubuntu)

   echo 256 | sudo tee -a /proc/sys/fs/inotify/max_user_instances
   echo 32768 | sudo tee -a /proc/sys/fs/inotify/max_queued_events
   echo 65536 | sudo tee -a /proc/sys/fs/inotify/max_user_watches

the above commands worked for me

0

I had the same issue. I fixed it by reinstalling the watchman package. If you are using mac do this brew uninstall watchman and then brew install watchman

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.